Sudden VM unavailability in us-central-1?

For many years I’ve been deploying compute engine VMs to us-central-1 region but for the past couple days I’ve constantly received error ZONE_RESOURCE_POOL_EXHAUSTED when creating VMs.

I tried a,b,c, and f. Same issue.

I tried e2,n1,n2. Same issue.

Currently working around this with t2d instances, but not sure if that will hold up.

I would prefer to keep everything in us-central-1 if possible. Is there an ongoing issue here or is this region just suffering from lack of compute?

Been experiencing the same issue here when spinning up compute in a new gcp project. Occurs for n1, n2, & n2d (-16 & under) in all AZs in us-central-1. Assumed it was a temporary resource shortage but it’s been happening consistently for the past week, which has been very frustrating. Have been able to work around it by spinning things up in us-west2 && us-east1, but even west2 is starting to be short of compute.

Seems like it’s only affecting my newer project though, as I’m able to spin up the same machine types in a more mature project. I’ve also validated it’s not a quota issue.

It’d be great to see this resolved soon!!

I’m experiencing the same thing today. What’s causing this? I really don’t want to change regions because of all my other resource configs. But I’m going to have to I guess since not even t2d worked for me in us-central-1.

Same here - can’t boot my VM with same ZONE_RESOURCE_POOL_EXHAUSTED error.

I’m having the same problem. Tried us-central-1 and us-west-2. I guess GCP doesn’t want my money anymore shrug