Redis Memstore Cluster IAM Credentails

Hi,

We have redis memstore cluster and in producion we would like to have IAM credentials enabled.

i followed https://cloud.google.com/memorystore/docs/cluster/client-library-connection#lettuce_2

Have created a service account and given roles

roles/redis.dbConnectionUser and roles/iam.serviceAccountTokenCreator

As per the documentation https://cloud.google.com/memorystore/docs/cluster/client-library-connection#lettuce_2, the accountName is the service account which i have created and using the same.

But i get an error PERMISSION_DENIED: Permission ‘iam.serviceAccounts.getAccessToken’ denied on resource (or it may not exist).

Hello @knhemanth ,Welcome on Google Cloud Community.

Please grant role Service Account Token Creator to your newly created service account.


cheers,
DamianS
LinkedIn medium.com Cloudskillsboost

Hello @DamianS

Thanks for the reply, i have given the roles

Service Account Token Creator and Cloud Memorystore Redis Db Connection User

Please find the screen shot below.

Is there anything i should be doing ?

@DamianS

I have given the roles, please find the screen shot below.

Am i missing something ?

Hi @DamianS

I have granted Service Account Token Creator to the SA.

Please find the screen shot below.

Hello,

Thank you for contacting the Google Cloud Community.

If the issue is still not resolved please contact GCP Support1. Our support team will prioritize your request and provide you with the assistance you need.

We appreciate your cooperation!